Problem:
Prøver/analyser kommer ikke ned fra Jupiter
I Jupiter loggen er der fejl:
Indlæsning af prøver og analyser fejlede: An error occurred while updating the entries. See the inner exception for details.An error occurred while updating the entries. See the inner exception for details.
SqlDateTime overflow. Must be between 1/1/1753 12:00:00 AM and 12/31/9999 11:59:59 PM.
Årsag:
Der er en eller flere prøver i Jupiter, som har et forkert dato-format.
Servicen stopper derfor med at importere prøver.
Løsning:
Identificer de problematiske prøver.
Man kan f.eks. bestille et udtræk på GEUS' hjemmeside i PC Jupiter XL format - her kan man se prøverne.
Her er f.eks. 3 prøver med udtagelsesdato 3. januar 0001, som forårsager problemet:
SAMPLEID | PLANTID | SAMPLEDATE |
1274090 | 183528 | 0001-01-03 00:00:00.0000000 |
1279101 | 183528 | 0001-01-03 00:00:00.0000000 |
1325126 | 184186 | 0001-01-03 00:00:00.0000000 |
Kontakt GEUS for at få rettet de forkerte datoer.
Fra og med GeoEnviron 9.9.0 vil Jupiter servicen give en fejl ved sådan et problem, men vil importere øvrige prøver.
Kommentarer
0 kommentarer
Artiklen er lukket for kommentarer.